AI Security Mailbox Report Processing Disruption

Incident Report for Abnormal AI

Resolved

Between approximately 16:00 UTC and 23:50 UTC on March 26, 2026, Abnormal experienced a service disruption impacting AI Security Mailbox report processing for US and EU customers. During this time, new reports submitted to AI Security Mailbox may not have been processed as expected. Abnormal engineers deployed a fix at 23:50 UTC and confirmed that services are now processing in real time. Any reports submitted during the impacted window are currently being reprocessed and are expected to be fully completed within the next few hours. If you experience any further issues, please reach out to the Abnormal support team at support@abnormalsecurity.com.
Posted Mar 26, 2026 - 17:14 PDT

Identified

Starting at approximately 16:00 UTC on March 26, 2026, Abnormal began experiencing an issue with AI Security Mailbox report processing. US and EU customers may experience failures in the processing of new reports submitted to AI Security Mailbox. Abnormal engineering is actively investigating and working to restore full functionality.
Posted Mar 26, 2026 - 16:03 PDT
This incident affected: AI Security Mailbox (AISM).