Inbound Email Security and Email Productivity – (EU)

Incident Report for Abnormal Security

Resolved

As of 00:53 UTC, our engineering team has successfully resolved the issue impacting Inbound Email Security and Email Productivity in the EU. Emails affected during the incident window have been reprocessed and remediated.
If you experience any further issues, please reach out to our support team at support@abnormalsecurity.com
Posted Apr 17, 2025 - 18:51 PDT

Investigating

Starting at 23:50 UTC on April 17th, Abnormal began experiencing service degradation affecting Inbound Email Security and Email Productivity. EU customers may experience delayed email remediation. Our engineering team is actively working to mitigate the issue and restore full functionality.
We will provide the next update within the next hour or sooner as more information becomes available.
Posted Apr 17, 2025 - 17:52 PDT
This incident affected: Inbound Email Security (IES) and Email Productivity (EPR).