Starting around 14:40 UTC, Abnormal experienced an issue with the EU Portal being inaccessible and displaying an error to EU customers. Email detection and remediation services were not impacted during this time and continued to operate normally. Access to the Abnormal Portal for EU customers has been restored as of 15:01 UTC. If you experience any further issues, please reach out to the Abnormal support team at support@abnormalsecurity.com.
Posted Mar 16, 2026 - 08:05 PDT
Investigating
Starting around 14:26 UTC, Abnormal began experiencing an issue with the EU Portal being inaccessible and displaying an error. EU customers may be unable to access the Abnormal Portal during this time. Email detection and remediation services remain fully operational and are not impacted. The engineering team is actively working to restore access to the EU Portal.
Posted Mar 16, 2026 - 07:58 PDT
This incident affected: Platform (Portal Application).