Abnormal's engineering team has fully resolved the Portal access issue. All customers can now successfully log in to the Portal, and services are operating normally. Email security protection remained fully operational throughout this incident. No further updates will be provided for this issue. If customers experience any further issues, please reach out to support@abnormalsecurity.com.
Posted Nov 06, 2025 - 16:20 PST
Monitoring
Portal services have remained stable since 21:10 UTC, and all customer access has been fully restored. Abnormal's engineering team continues working to address some underlying issues to prevent recurrence. Email security protection, including threat detection and remediation, remains fully operational and unaffected. The next update will be provided when this issue is fully resolved.
Posted Nov 06, 2025 - 15:04 PST
Identified
Abnormal's engineering team has made progress resolving the Portal access issue. Some customers in the US region are now able to successfully log in to the Portal. Engineers continue working to fully restore Portal access for all customers. Email security protection, including threat detection and remediation, remains fully operational and unaffected. Updates will be provided as the situation progresses.
Posted Nov 06, 2025 - 13:18 PST
Investigating
Starting around 20:25 UTC (1:25pm PT), Abnormal began experiencing an issue with the Portal login functionality impacting US customers. Customers may experience issues accessing the Abnormal Portal. Email remediation and detection services remain fully operational and unimpacted. Engineers are actively investigating the root cause and working to restore full Portal access.
Posted Nov 06, 2025 - 12:46 PST
This incident affected: Platform (Portal Application).