Inbound Email Security Message Remediation Delays – (EU)

Incident Report for Abnormal Security

Resolved

As of 20:25 UTC, the backlog of messages from the incident has been fully processed. Message remediation for Inbound Email Security impacting EU customers has fully recovered, and the issue is now resolved.

If you experience any further issues, please don’t hesitate to reach out to our customer support team at support@abnormalsecurity.com. We appreciate your patience throughout this incident.
Posted Mar 27, 2025 - 13:30 PDT

Monitoring

As of 18:10 UTC, we’ve begun to see recovery in message remediation for Inbound Email Security impacting EU customers. Our team is now focused on processing the backlog of messages accumulated during the incident to ensure full restoration of service. Thank you for your continued patience as we work to resolve this.
Posted Mar 27, 2025 - 11:11 PDT

Investigating

Starting around 16:00 UTC, Abnormal began experiencing message remediation delays affecting Inbound Email Security for our EU customers due to backend system errors. Our engineering team is actively investigating and working to restore full functionality. We’ll provide the next update within 60 minutes or sooner as more information becomes available.
Posted Mar 27, 2025 - 10:28 PDT
This incident affected: Inbound Email Security (IES).